We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Data
Data Sets
Generate
Machine Learning
Math
Mesh
Models
Panels
Serialization
Structure
Trainer Types
Util
Workflow

LunchBox

ADDON. Version 2023.2.2.0. Released on 2020-Jun-30. Provides 157 components. Created by Nathan Miller. Features 23 video tutorials.
LunchBox is a collection of computational design tools for Grasshopper and Dynamo. The plugins include new component nodes for managing data and geometry for activities such as generative form making, paneling, rationalization, and interoperability. LunchBox also includes new general-purpose Machine Learning components built on the Accord.NET framework.

Trainer Types

Average Perceptron Binary Classifier (Avg Perceptron)
The Average Perceptron Binary Classifier is used to train a linear binary classification model trained over boolean label data.
Fast Forest Binary Classifier (Fast Forest)
The Fast Forest trainer is used for training a decision tree binary classification model using the Fast Forest method.
Fast Forest Regression (Fast Forest)
The Fast Forest trainer is used for training a decision tree regression model using the Fast Forest method.
Fast Tree Binary Classifier (Fast Tree)
The Fast Tree trainer is used for training a decision tree regression model using the Fast Tree method.
Fast Tree Regression (Fast Tree)
The Fast Tree trainer is used for training a decision tree regression model using the Fast Tree method.
Fast Tree Tweedie Regression (Fast Tree Tweedie)
The Fast Tree Tweedie trainer is used for training a decision tree regression model using the Fast Tree Tweedie method.
Field Aware Factorization Machine Binary Classifier (Factorization)
The Field Aware Factorization Machine Binary Classifier is used to train a model using a stochastic gradient method.
Generalized Additive Models Binary Classifier (GAM)
The GAM trainer is used for training a binary classification model with Generalized Additive Models (GAM).
Generalized Additive Models Regression (GAM)
The GAM trainer is used for training a regression model with Generalized Additive Models (GAM).
Lbfgs Logistic Regression Binary Classifier (Lbfgs Logistic Regression)
The Lbfgs Logistic Regression Binary Classification trainer is used to train linear logistic regression models trained with the L-BFGS method.
Lbfgs Maximum Entropy Multiclass Classifier (Lbfgs Maximum Entropy)
The Lbfgs maximum entropy model is a generalization of linear regression
Lbfgs Poisson Regression (Lbfgs Poisson)
The Lbfgs Poisson trainer is used for training Poisson regression models.
Local Deep SVM Binary Classifier (LDSVM)
The Local Deep SVM Binary Classification trainer is used to train a non-linear binary classification model using the Local Deep SVM method.
Light GBM Binary Classifier (Light GBM)
The Light GBM classifier trains a model using a gradient boosting decision tree binary classification method.
Light Gbm Multiclass Classifier (Light Gbm)
The LightGBM trainer is an open source implementation of gradient boosting decision tree.
Light GBM Regression (Light GBM)
The Light GBM trains a model using a gradient boosting decision tree regression method.
Linear SVM Binary Classifier (Linear SVM)
The Linear SVM Binary Classification trainer is used to train a linear binary classification model using the Linear SVM method.
Naive Bayes Multiclass Classifier (Naive Bayes)
The Naive Bayes trainer is a probabilistic classifier that can be used for multiclass problems
Ordinary Least Squares Regression (OLS)
The Ordinary Least Squares trainer is used for training a linear regression model using the ordinary least squares (OLS) method for estimating parameters of the linear regression model.
Online Gradient Descent Regression (Online Gradient Descent)
The Online Gradient Descent Trainer is used to train a linear regression model using the online gradient descent method to estimate the parameters for the linear regression model.
SDCA Logistic Regression Binary Classifier (SDCA Logistic Regression)
The SDCA Logistic Regression Binary Classification trainer is used to train logistic regression classification models trained with the stochastic dual coordinate ascent method.
Sdca Maximum Entropy Multiclass Classifier (Sdca Maximum Entropy)
The Sdca maximum entropy model is used to predict a target using a linear multiclass classifier model trained with a coordinate descent method.
SDCA Noncalibrated Binary Classifier (SDCA Noncalibrated)
The SDCA Noncalibrated Binary Classification trainer is used to train logistic regression classification models trained with the stochastic dual coordinate ascent method.
Sdca Noncalibrated Multiclass Classifier (Sdca Noncalibrated)
The Sdca noncalibrated model is used to predict a target using a linear multiclass classifier model trained with a coordinate descent method.
Sdca Regression (Sdca)
The Sdca trainer is used to train a regression model using the stochastic dual coordinate ascent method.
SGD Calibrated Binary Classifier (SGD Calibrated)
The SGD Calibrated trains a linear classification model using the parallel stochastic gradient descent (SGD) method
SGD Noncalibrated Binary Classifier (SGD Noncalibrated)
The SGD Noncalibrated trains a linear classification model using the parallel stochastic gradient descent (SGD) method
Symbolic SGD Logistic Regression Binary Classifier (Symbolic SGD)
The Symbolic SGD Logistic Regression classifier trains a linear binary classification model using the symbolic stochastic gradient descent (SGD) method

Util

Arc Divide (ArcDivide)
Divides a spline curve into tangent arc segments.
Deconstruct Wireframe (DeWire)
Organizes a wireframe curve structure into nodes and centerlines
Flatness Check (Flat)
Checks the flatness of a quad panel.
Mesh Edges (with Tolerance) (MshEdge)
Finds naked mesh edges and edges between faces greater than a specified angle.
Mesh Reduce (MshReduce)
Reduce mesh polygons to simplify.
Patch Surface (Patch)
Returns a patch surface using a list of edge curves. (Rhino 5 only)
Random Split List (RandomSplit)
Randomly splits a list into two lists.
Rebuild Surface (RebuildSrf)
Rebuilds an untrimmed surface using U and V parameters.
Relative Coordinates (Relative)
Returns coordinates of a point relative to a plane.
Reverse Surface Direction (RevSrf)
Reverse the UV directions of a surface.
Sort Duplicate Breps (Sort Brep)
Sort a list of Breps based on duplicates.
Sort Duplicate Curves (Sort Crv)
Sort a list of curves based on duplicates using document tolerances.
Sort Duplicate Points (Sort Pts)
Sort a list of points based on duplicates.
Sort Duplicate Values (Sort Val)
Sort a list of numbers or strings based on duplicates.
Unroll Brep (Unroll)
Unroll a brep or surface.
RTree Closest Point (RTree CP)
Find the closest point in an RTree from search points
Create RTree (RTree)
Creates a searchable RTree
RTree Points in Range (RTree Range)
Find points in an RTree within range of search points
Brep Join with Tolerance (BrepJoin)
Join Brep faces with a tolerance value.
Brep Join Progression (BrepJoin)
Progressively join Brep faces with a tolerance value. Faces are progressively joined together in the order they are supplied.
Sort Adjacent Brep Faces (Adjacent)
Returns a sorted structure of Brep faces adjacent to other faces.

Machine Learning

Codify Data
Codify data to be used in various classifier models.
Load Model
Deserialize a model from a saved file (*.bin)
Gaussian Mixture (GaussianMix)
Solver for Gaussian Mixture models.
Confusion Matrix Properties (Confusion Matrix)
This component exposes the properties of a General Confusion Matrix
Hidden Markov Model (HiddenMark)
Solver for Hidden Markov Model problems.
K-Means Clustering (K-Means)
Solver for K-Means Clustering.
Linear Regression (LineReg)
Solver for linear regression problems.
Logistic Regression (LogReg)
Solver for Logistic regression problems.
Multivariate Linear Regression (MultiLineReg)
Solver for multivariate linear regression problems.
Naive Bayes Classification Tester
This component tests an adaptive naive bayes classifier.
Naive Bayes Classification Trainer
This component trains an adaptive naive bayes classifier algorithm based on a training data set.
Neural Network Tester
Test a solution using a trained neural network solver.
Neural Network Trainer
This component uses the resilient backpropagation (RProp) learning algorithm to train neural networks.
Restricted Boltzmann Machine (ResBoltz)
Solver for Restricted Boltzmann machines.
Nonlinear Regression (NonlineReg)
Solver for nonlinear regression problems using Sequential Minimal Optimization.
Kernel SVM Tester (SVM Tester)
This component tests an kernel-based Support Vector Machine (SVM) classifier.
Kernel SVM Trainer (SVM Trainer)
This component trains a kernel-based Support Vector Machine (SVM) on an input training data set.

Data Sets

Create Data Set (Create)
Create a data set which can be use for training a machine learning algorithm.
Text Loader Options (Options)
Additional options to control how a data file is loaded.
Featurize Text (Featurize)
Transforms a text column into a featurized vector of numbers that represents normalized counts of n-grams and char-grams.
Filter Data
Filter data based on the values of a column.
Get Column Label (Column Label)
Get the names of the columns in a data set.
Load Data From Text File (Load Data)
Load a data set from a file.
Normalize Data (Normalize)
Normalizes the values of a column in a data set.
One Hot Encoding (Encoding)
Converts one or more input text columns into as many columns of one-hot encoded vectors
Peek At Data (Peek Data)
Peek at a small sample of the contents of a ML data set
Remove Columns
Remove columns from a data set.
Replace Missing Data (Replace Data)
Replace missing data in a column.
Select Columns
Select columns from a data set.
Split Data
Split a loaded data set into training and testing subsets of data.
Tokenize Into Words (Tokenize)
Split one or more text columns into individual words.

Math

Enneper Surface (Enneper)
Create a parametric Enneper surface.
Helicoid Surface (Helicoid)
Create a parametric Helicoid surface.
Klein Surface (Klein)
Create a parametric Klein surface.
Mobius Surface (Mobius)
Create a parametric Mobius surface.
Hyperbolic Paraboloid (Paraboloid)
Create a parametric paraboloid surface.
Conoid Surface (Conoid)
Create Plucker's Conoid surface.
3D Supershape (3DSupershape)
Create a parametric 3D supsershape
Torus Surface (Torus)
Create a parametric torus surface.
Platonic Cube (PlatoCube)
Create a parametric cube with a truncation parameter.
Platonic Dodecahedron (PlatoDodec)
Create a dodecahedron.
Platonic Icosahedron (PlatoIcosa)
Create a parametric icosahedron with a truncation parameter.
Platonic Octahedron (PlatoOcta)
Create a parametric octrahedron with a truncation parameter.
Platonic Tetrahedron (PlatoTetra)
Create a parametric tetrahedron with a truncation parameter.

Data

Create Chart (Chart)
Creates a saveable Winform chart.
Create Data Grid (DataGrid)
Creates a Data Grid view of data. Data can be saved as CSV file.
Create DataSet (DataSet)
Create a DataSet
Create DataTable (DataTable)
Create a DataTable
Create CSV (CSV)
Create a CSV string
Read CSV (CSV)
Read a CSV string. (Comma Separated Value)
Convert JSON to XML (JSON-XML)
Converts a JSON string to XML.
Create XML (XML)
Create XML from a DataSet
Read XML by Tag (XML)
Read XML data by tag.
Convert XML to JSON (XML-JSON)
Converts a XML string to JSON
Create JSON (JSON)
Create JSON from a DataSet

Panels

Diamond Panels (Diamond)
Creates diamond panels on a surface.
Diamond Grid (DGrid)
Creates a diamond corner point grid on a surface.
Hexagon Cells (Hex)
Creates hexagonal cells on surface.
Quad Panels (Quads)
Creates quadrangular panels on a surface
Quad Grid (QGrid)
Creates a quad corner point grid on a surface.
Random Quad Panels (QuadRand)
Creates randomly staggered quad panels on a surface
Staggered Quad Panels (QuadStag)
Creates staggered quad panels on a surface.
Skewed Quads (SQuads)
Creates 'skewed' quadrangular panels on a surface
Triangular Panels A (TriA)
Creates triangular panels on a surface.
Triangle Panels B (TriB)
Creates triangular panels on a surface.
Triangle Panels C (TriC)
Creates triangular panels on a surface.

Workflow

Object Bake (Bake)
Bake objects to a layer in the active Rhino document.
Create Layers (Layer)
Create a list of layers in Rhino.
Excel Reader (ExcelRead)
Reads an open Excel file.
Excel Write (ExcelWrite)
Write to an open Excel file.
Launch Application (LaunchApp)
Launch an external application or file
Layer Information (Layer Info)
Get layer information from the current document.
Layer Reference (Layer Ref)
Reference geometry on layers with GUIDs and Names.
Rhino Command (RhCOM)
Sends a command to the Rhino command-line.
Object Save (Save)
Saves geometry to a specified file location.

Structure

Braced Grid 1-D Structure (GridBraced1D)
Creates a 1-Direction braced grid structure on a surface.
Braced Grid 2-D Structure (GridBraced2D)
Creates a 2-Direction braced grid structure on a surface.
Diagrid Structure (Diagrid)
Creates a diagrid structure on a surface.
Grid Structure (Grid)
Creates a simple grid structure on a surface.
Hexagonal Structure (Hex)
Creates a hexagonal structure on a surface.
Space Truss Structure 1 (SpaceTruss 1)
Creates a space truss structure on a surface.
Space Truss Structure 2 (SpaceTruss 2)
Creates a space truss structure using two driver surfaces
2D Truss (Truss)
Creates a 2-D Truss using a set of edge curves.

Models

Load Saved Model (Load Model)
Deserialize a model from a saved file (*.zip)
Object Detection Using ONNX File (Image Classifier)
Use a pre-trained deep learning Open Neural Network Exchange (ONNX) file for object detection and image segmentation
Multiclass Classifier Tester
Test a model for multiclass classification problems.
Binary Classifier Tester
Test a model for binary classification problems.
Regression Tester
Test a model for regression problems.
Multiclass Classifier Trainer
Train a model for multiclass classification problems.
Binary Classifier Trainer
Train a model for binary classification problems.
Regression Trainer
Train a model for regression problems.

Generate

Attractor (Attract)
Generates a attractor values using lists of attractors and targets.
Attractor Wave (AttWave)
Generates a wave attractor effect using lists of attractors and targets.
Constant Quad Subdivide (ConstQuad)
Subdivides a triangular panel into quadrangular cells
Panel Frame (Frame)
Creates an offset frame using a panel.
Subdivide Quad (QuadSub)
Subdivides a quad into self-similar cells.
Subdivide Triangle (TriSub)
Subdivides a triangle into self-similar cells.

Serialization

Hash Objects (Hash)
Use a Secure Hash Algorithm (SHA) to hash geometry or strings.
Create GUID (GUID)
Creates a valid GUID (Globally Unique Identifier).
Decrypt Text (Decrypt)
Decrypt text with a passphrase.
Deserialize Geometry (Deserialize)
Deserialize string (JSON, XML, or Binary) to Grasshopper geometry.
Encrypt Text (Encrypt)
Encrypt text with a passphrase.
Serialize Geometry (Serialize)
Serialize Grasshopper geometry text formats (JSON, XML, or Binary).

Mesh

Mesh Extrude (MshExtrude)
Extrudes a mesh object along a specified vector.
Mesh Offset (MshOffset)
Offsets a mesh object using the vertex normals of the source mesh.
Mesh to Nurbs (MeshNurbs)
Convert the faces of a mesh to Nurbs surfaces.
Quad Remesh (Remesh)
Remeshes a Brep or Mesh object using Rhino's Quad Remesh feature.
Quad Remesh Parameters (Parameters)
Parameters to control the output of the Quad Remesh component.

Video Tutorials

Site design © Robin Rodricks.   LunchBox and associated data © 2024 Nathan Miller.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service