Best Practicizer (BestPracticizer) Takes a selected group and inserts input and output params at both edges for any data that goes outside the group. | |
Capture GH Canvas (CanvasCap) Capture a hi-res image of the GH Canvas | |
Wrap List (Wrap) Converts a list of data into a single object | |
Expire Object (Expire) Expire / recompute a component or param | |
Get List Data (ListData) Gets data from the Value List, Item Selector, etc components | |
Get Param Data (ParamData) Get the set of data in a given param | |
Get Slider Properties (SliderInfo) Gets the properties of the slider | |
Instantiate Object (Create) Attempts to create an instance of an object on the canvas | |
Internalize Param Data (Internalize) Internalize data into a param | |
Label Groups (LblGrp) Auto-create a scribble in the upper left corner of a group that matches the group's name | |
Highlight Objects (Hilite) Highlight objects by adding them a new group | |
Relative Path (RelPath) Appends the directory this definition is saved in to a file path. Auto-converts the contents of a text panel containing an absolute path | |
Get Runtime Messages (Msgs) Gets errors and warnings from selected objects | |
Select GH Object (Select) Select objects on the Grasshopper Canvas | |
Set Object Value (SetObj) Tries to set the value of an object. What value it sets varies by type - it sets a slider's numeric value, a panel or scribble's text contents, etc | |
Set Param Data (SetParamData) Set the data in a given param | |
SwapParamType (SwapParam) Switch the type of one param object to another | |
Unwrap List N Levels (UnwrapN) Unwraps data wrappers N levels (or all the way if N=0) | |
Unwrap List (Unwrap) Converts a data wrapper into a list | |
Wrap List N Levels (WrapN) Wraps and Path-shifts a list by N levels | |
AutoSwatch (Swatch) A shortcut for creating color swatches by name |
Bake Object (Bake) Programmatically bake the geometry of specified objects | |
Control Wire Display (WireDisplay) Control the display of wires for parameters and components. | |
Enable/Disable Object (OnOff) Programmatically enable/disable solving for specified objects | |
Move Object (Move) Reposition an object on the GH canvas | |
Rename Object (Rename) Programmatically set the nickname of specified objects | |
Set Group Properties (SetGroup) Set the name, color, and style of a group. | |
Hide/Show Object Preview (HideShow) Programmatically control the preview visibility of specified objects | |
Set Panel Properties (SetPanel) Modify the properties of a panel object | |
Set Scribble Properties (SetScribble) Set the text, size, and font of a Scribble. | |
Set Sketch Modify the form of an existing sketch object. | |
Set Slider Properties (Set Slider) Modify the properties of a slider object | |
Wire Display Toggle (WireToggle) Switch all document wires between hidden and faint. |
Get Connected Objects (Connected) Gets all components and params connected to this component | |
Get Groups (Groups) Get all groups in the document | |
Get Objects in Group (ObjFromGroup) Gets all components and params in the same group as this component (or the specified group if supplied) | |
Get Scribbles (Scribbles) Get all Scribbles in the document | |
Get Objects of Same Library (SameLib) Gets all components and params that are from the same library as the attached. | |
Get Objects of Same Type (SameType) Gets all components and params that are of the same type as the attached. | |
Get Selected Objects (SelObj) Get the objects currently selected on the canvas | |
Get Object By Nickname (ObjByNN) Retrieves all objects matching the specified nickname. Wildcard patterns accepted. |
Assembly Info Gets information about an assembly | |
Component Info Get information about a component object. Retrieve components with Document Info, Get Attached Component, or Get Selected Component. | |
Document Info (DocInfo) Get information about the GH document and its components | |
Object Info Gets basic information from any DocumentObject | |
Param Info Gets information about param objects |
Batch Animator (BAnim) Saves a screenshot of every state of the model in the batch to a folder. | |
BatchDriver Run a batch analysis across a range of variable parameters | |
Batch Variable from List (BVarList) Converts a list of values such as a series or range into a variable input to the Batch Driver | |
BatchSlider (BSlider) Converts a standard GH Slider into a variable input to the Batch Driver |
Site design © Robin Rodricks.
MetaHopper and associated data © 2024 Andrew Heumann.
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.
Hosted by GitHub