We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
_
Data
File I-O
Geometry
Mesh
Mesh-Create
Topology
View/Display

FroGH

ADDON. Version 2.2.9. Released on 30-Dec-2023. Provides 93 components. Created by Co-de-iT (Computational Design Italy). Features 0 video tutorials.
froGH is a sparse collection of components born out of necessity or play in our daily Grasshopper experience.

Geometry

Clusterize Points By Distance (f_PtsCBD)
Clusterize a list of points by distance
Get Euler Angles ZYX (f_EuZYX)
the Euler angles for a rotation transformation in ZYX order
Also known as Yaw, Pitch, Roll
Get Euler Angles ZYZ (f_EuZYZ)
the Euler angles for a rotation transformation in ZYZ sequence
Most common in robotics
L Polyline From Plane (f_LPP)
Generates an L shaped polyline (X-O-Y order) from a Plane
Points In Sphere (RTree) (f_PtsSphRT)
Detects Points within a Sphere of given center and radius in a given RTree
Use this for fixed search sets
For dynamic search sets use the other Points In Sphere
Rotation from ZYX Euler Angles (f_RotZYX)
Create a Rotation Transform from Euler Angles ZYX (aka yaw, pitch, roll)
Rotation from ZYZ Euler Angles (f_RotZYZ)
Create a Rotation Transform from Euler Angles ZYZ
RTree Closest Point (f_RTreeCP)
Returns the Closest Point to a given RTree
Smallest Enclosing Circle (f_SEC)
Finds the Smallest Enclosing Circle for the given points in the given plane
original code Copyright (c) 2020 Project Nayuki
https://www.nayuki.io/page/smallest-enclosing-circle
Text To Geometry (f_T2Geom)
Converts text into geometry (Polylines, Curves or Surfaces)
use single-line fonts for best results in fabrication
Adaptive Fillet (f_AdFlt)
Fillets a polyline proportionally to the segment length and angle
Divide Curve By Tangent Angle (f_DivTanAng)
Adaptively Divides a Curve By Tangent Angle threshold
Frenet Serret Frame (f_FSFrame)
Solves the Frenet-Serret Frame (Tangent, Normal and Binormal) for a Polyline
Flapper (f_Flap)
builds flaps on a planar mesh naked edges
Suggested use with mesh strips
Automatic compensation for overlaps
Is Polyline Clockwise (f_PlCW)
Determines if a planar Polyline direction is clockwise
Orient 3 Points_DEPRECATED (f_C3PO)
Orient objects by sets of 3 points
Plane From L Polyline (f_PLP)
Generates a plane from an L shaped polyline (X-O-Y order)
Points In Sphere (f_PtsSph)
Detects Points within a Sphere of given center and radius
Use this in case of dynamic sets to search
For fixed sets, use the RTree version
Sort Points By Angle (f_PtsByAng)
Sorts a list of points by angle from their average point
Surface QuadTree By Curvature (f_SQTreeK)
Subdivides iteratively a surface based on local curvature
Surface QuadTree By Curve (f_SQTreeC)
Subdivides iteratively a surface based on a set of curves
Trilateration (f_TriLat)
Finds intersection of 3 spheres with algebraic method
(faster than geometric intersection of solids)
Signed Vector Angle (f_SVAng)
Computes angle between vectors with direction-dependent sign
clockwise is -, counter-clockwise is +

Mesh

Extract Mesh Edges (f_MEdges)
Extract Mesh Edges as Lines
Mesh Point Inside (f_MPInside)
Verify if a Point is inside or outside a closed Mesh
This component uses the Mesh Winding Number (MWN) method
see Jacobson et al http://igl.ethz.ch/projects/winding-number/
Mesh Report (f_MRep)
Generates a report on a Mesh geometry.
Previews naked (Magenta) & non-manifold (Blue) edges
Extract Mesh Faces (f_MFaces)
Extract Mesh Faces (by index) as Mesh
Mesh Connectivity - Edge Proximity Map (f_MC-EPM)
Mesh edge-centered Topological connectivity map
Mesh Connectivity - Edge Proximity Single (f_MC-EPS)
Mesh Topological connectivity for a single edge
Mesh Connectivity - Face Proximity Map (f_MC-FPM)
Mesh face-centered Topological connectivity map
Mesh Connectivity - Face Proximity Single (f_MC-FPS)
Mesh Topological connectivity for a single face
Mesh Connectivity - Vertex Proximity Map (f_MC-VPM)
Mesh vertex-centered Topological connectivity map
Mesh Connectivity - Vertex Proximity Single (f_MC-VPS)
Mesh Topological connectivity for a single vertex
Mesh Closest Vertex Index (f_MCVi)
Closest vertex index in a mesh (absolute and face-relative) for a given list of points
Mesh De-Noising (f_MDN)
Reduces noise in a mesh (i.e. from scanned pointclouds or messy ones)
algorithm by Paul Bourke - 1997 - http://paulbourke.net/geometry/polygonmesh/
Meshes Extract Edges with tolerance angle (f_MmEEA)
Extract Mesh edges with specific angle tolerance.
Optimized for many meshes
Mesh Extract Edges with tolerance angle (f_MsEEA)
Extract Mesh edges with specific angle tolerance.
Optimized for a single mesh
Mesh Faces To Vertices Values (f_MF2VVal)
Converts per-face into per-vertex values
Mesh Isocurves (f_MIso)
Generates isocurves on colored quad meshes
Mesh Pseudo-Curvature (f_MPC)
A quick and dirty method to evaluate something like curvature on triangulate meshes
This one seems to have a penchant for peaks and valleys
Mesh Rebuild Normals (f_MReNorm)
Rebuilds Mesh Normals
Mesh Subdivide Quad Faces (f_SubMQF)
Subdivides a Quad Mesh Face in a custom UV number of sub-faces
Mesh To C# Snippet (f_M2CS)
Generates C# code for a given Mesh
Mesh Unlooper (f_MUnl)
Opens closed Mesh loop strips
Mesh Vertices To Faces Values (f_MV2FVal)
Converts per-vertex into per-face values
Reduce Mesh (f_RedMesh)
Reduce Mesh polygon count

Data

Create RTree (f_CRTree)
Creates an RTree from Points, PointClouds or Meshes
DataTreeGraph (f_DTG)
Generates a graphics representation of a Data Tree inscribed in an input Circle
Original VB
Froggle (f_Fro)
Like a Toggle, but flipped by a Button
you can also double click on the component to flip status
BY DESIGN, it resets to False when opening a file containing it,
and the Froggle status flips only when a True value is input
SelectRhinoObjects (f_SelRhObj)
Select referenced Objects in Rhino by their GUID
All kinds of Rhino entities can be selected
Toggle Autostop (f_TAS)
Stops a Toggle (reverting its status from True to False) when a condition is met
Bake Attributes Enhanced (f_Bake++)
Bakes objects with attributes (such as color, material, layer, object name, isocurve density)
Option for baking into groups
Centered Domain (f_CDom)
Generates a domain of length L, centered in 0
Deconstruct Block From ID (f_BlDecon)
Deconstructs a Rhino Block from its name
Deconstruct Dot (f_DotDecon)
Deconstructs a Rhino Dot Object
(best used in combination with Deconstruct Block)
Double Shift (f_DShift)
Performs a double shift on a list - with optional wrap
Indexes From List (f_iFromL)
Generates a list of 0-based integer indexes from a given list of data
IndexesFromNumber (f_iFromN)
Generates a list of 0-based integer indexes from a given amount
Mass Boolean (f_MassBool)
Mass boolean operator on a list of values
ObjectLayer (f_OLay)
Gets the Layer of a Rhino referenced object
Serial Branch Path (f_SBPath)
Retrieves the data tree path and data for a specific branch serial index
Symmetric Domain (f_SDom)
Generates a (-X, X) domain
Weighted Random Choice (f_WRC)
Generates weighted random sequences from a given list of values and weights

View/Display

Camera Control And Zoom To Geometry (f_CamConZ2Geo)
Controls Rhino camera from Grasshopper, with the ability to Zoom to a given geometry
CameraReport (f_CamRep)
Gets information about Rhino view camera
Custom Material (f_MatC)
Create Custom Render Materials
Custom Mesh Vertices Display (f_CMVD)
Render-compatible custom Mesh vertices display
Custom Mesh Wires Display (f_CMWD)
Render-compatible custom Mesh wires display
Named Views To Cinema 4D (f_NV2C4D)
Translates Named Views Data for Cinema 4D
Orient To Camera (f_O2Cam)
Creates a Camera-aligned Plane centered on a given point
PointCloud Display (f_PCD)
Render-compatible Point Cloud display
Slider Value display (f_SlVDisp)
Display Slider values on screen
Turntable (f_TT)
Simulates a turntable animation around selected objects
View Capture To File (f_VC2F)
Saves a bitmap of the selected Rhino viewport - with options
Make sure this object is on top of all other objects
(i.e.executes last)
Weighted Spheres Cloud Display (f_WSCD)
Render-compatible Weighted Sphere Cloud display
Suitable for volumetric scalar field display

File I-O

COM Port Writer (f_COMpW)
Sends data to a COM port
Export Curves to AI (f_AIexp)
Export curves to Adobe Illustrator format, retaining layers
Save GH File (f_GHSave)
Saves a copy of the current GH document as a new file
Use with a Button or a Froggle (not a Toggle)
Directory Reader (f_DirRead)
Returns the list of Files and subdirectories in a Directory
Double click the component to update
GH File Path Info (f_GHFilePath)
Provides info on current Grasshopper Document file name and path
Useful for exporting files with the same name as the gh file and in the same directory
Load STL Binary File (f_STLBinLoad)
Loads a Binary STL Mesh file
Path Generator (f_PathG)
Generates a path based on local directories such as Desktop, Documents, GH file path
Read File From URL (f_URLr)
Reads a file from a URL
Save String To File (f_Str2File)
Saves a text sequence to a file

Mesh-Create

Mesh Offset Extended (f_MeshOffEx)
Offsets a Mesh using several possible options
Integrates algorithms by Daniel Piker, from this post:
https://discourse.mcneel.com/t/proper-mesh-offset/148952/8
Fast Mesh From Polyline (f_FMesh)
Creates a fast mesh from a closed polyline
Mesh Bridge (f_MBridge)
Builds a Mesh Bridge between lists of points
Polylines Mesh Loft (f_PMLoft)
Lofts polylines with the same number of vertices into a mesh
Space-Filling Polyhedra Generator (f_SPHGen)
Creates a space filling Polyhedron

Topology

Clusterizer (f_Clstr)
Groups topology data into clusters of indexes
Topologizer (f_TLN)
Solves line network topology
Topology Inverter (f_TInv)
Invert topology tree indexes
ex. in a network, from nodes sorted by lines
to lines sorted by node and vice - versa

_

A wise frog (froGH)
Here's some simple advice:
Always be yourself

Site design © Robin Rodricks.   FroGH and associated data © 2024 Co-de-iT (Computational Design Italy).  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service