We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Benchmarking
Containment
Extensions
Intersection
Physical
Quick
Test

Impala

ADDON. Version 1.0. Released on 2018-Aug-30. Provides 41 components. Created by Dan Cascaval. Features 0 video tutorials.
Impala replicates common bottleneck Grasshopper operations with a focus on efficiency, allowing complex scripts and static simulations embedded within Grasshopper to make use of all available computational capacity. This is primarily evident in scripts that deal with thousands of objects or rely heavily on numerical or physically-based computations. The primary target audience is experienced design computation practitioners and Grasshopper users who are running into the upper bounds of the tool's native, single-core performance, and are willing to take a finer approach to boosting performance at key points. Impala focuses primarily on replicating existing Grasshopper functionality and developing an environment suitable to seamless integration of performant or multithreaded computation within GH.

Quick

Quick Abs (qAbs)
Absolute value of a number.
Quick Add (qAdd)
Adds two numbers or integers together.
Quick AEQ (qAEQ)
Checks two numbers for equality in tolerance
Quick Avg (qAvg)
Averages a list of numbers.
Quick Bounds (qBounds)
Gets 1D bounds for a list of numbers
Quick Divide (qDiv)
Divides two numbers or integers.
Quick Eq (qEq)
Checks two numbers for equality
Quick GT (qGT)
Test two numbers within a tolerance
Quick LT (qLT)
Tests two numbers within a tolerance
Quick Mod (qMod)
Modulus of two numbers
Quick Multiply (qMult)
Multiplies two numbers or integers together.
Quick Neg (qNeg)
Negative of a number
Quick Subtract (qSub)
Subtract two numbers or integers.
Vector Avg (vAvg)
Averages a list of vectors of points.
Vec Add (vAdd)
Add two points or vectors.
Vector Bounds (vBounds)
Gets 2D bounds for a list of Points or Vectors
Vec Subtract (vSub)
Subtract two points or vectors.

Physical

Par Closest Curve CP (ParCCCP)
Finds the closest point on a curve in a set of curves.
Par Curve CP (ParCurveCP)
Closest Point on a curve to a sample, within a tolerance.
Par Divide Length (ParDivLen)
Divide a curve into segments with a preset length.
Par Mesh CP (ParMeshCP)
Closest point on a mesh to a sample point
Par Point CP (ParPointCP)
Find the k closest points in a set to a sample point
Par Shatter (ParShatter)
Shatter the curve along selected parameters.
Halton Sequence (PopHalton)
Generate random points within a bounding area

Intersection

Par Brep Line Intersect (ParBLX)
Test whether a line and brep intersect.
Par Curve Curve Intersect (ParCCX)
Test whether a pair of curves intersect.
Par Iso Vist2D (ParIso2D)
Shoot a ring of rays at a set of obstacles.
Par Iso Vist3D (ParIso3D)
Shoot a ring of rays at a set of obstacles.
Par Mesh Curve Intersect (ParMCX)
Test whether a mesh and a curve intersect.
Par Mesh Ray Intersect (ParMeshRay)
Shoot a ray at a mesh.

Containment

Par Brep Inc (ParBrepInc)
Test whether a point is inside a closed brep.
Par MBrep Inc (ParMBrepInc)
Test whether a point is inside a closed brep.
Par Mesh Inc (ParMeshInc)
Test whether a point is inside a closed mesh.
Par MMesh Inc (ParMMeshInc)
Test whether a point is inside multiple closed meshes.
Par Point In Curve (ParPtinCrv)
Test whether a point is inside a closed curve.
Par Point In Curves (ParPtInCrvs)
Test whether a point is inside multiple curves.

Benchmarking

Bench Group (GStopWatch)
Returns the runtimes of all components in its group.
Bench Component (StopWatch)
Returns the runtimes of all its inputs on any recompute.

Extensions

Par Mesh Flow (ParMeshFlow)
Find flow lines along a mesh according to a gravitational vector
Par Visual Center (ParVisCen)
Find the visual center of a closed curve.

Test

Parallel Div (TestDivPar2)
Impala Generic testing

Site design © Robin Rodricks.   Impala and associated data © 2024 Dan Cascaval.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service