We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️

Gets Data from the RFEM Model.

Inputs

NameIDDescriptionType
Run component?RunIf true, the programm is executed.Boolean
NodesNodesNodes to get from the RFEM Model.Boolean
LinesLinesLines to get from the RFEM Model.Boolean
MembersMembersMembers to get from the RFEM Model.Boolean
SurfacesSurfacesSurfaces to get from the RFEM Model.Boolean
OpeningsOpeningsOpenings to get from the RFEM Model.Boolean
Nodal SupportsNodSupNodal Supports to get from the RFEM Model.Boolean
Line SupportsLineSupLine Supports to get from the RFEM Model.Boolean
Surface SupportsSrfcSupSurface Supports to get from the RFEM Model.Boolean
Member HingesMemberHingesMember Hinges to get from the RFEM Model.Boolean
Member EccentricitiesMemberEccMember Eccentricities to get from the RFEM Model.Boolean
Line HingesLineHingesLine Hinges to get from the RFEM Model.Boolean
Nodal ReleasesNodalReleasesNodal Releases to get from the RFEM Model.Boolean
Line ReleasesLineReleasesLine Releases to get from the RFEM Model.Boolean
Line Release TypesLineReleaseTypesLine Release Types to get from the RFEM Model.Boolean
Cross SectionsCroSecsCross Sections from the RFEM Model.Boolean
MaterialsMatMaterials to get from the RFEM Model.Boolean
Nodal LoadsNLoadsNodal Loads from the RFEM Model.Boolean
Line LoadsLLoadsLine Loads from the RFEM Model.Boolean
Member LoadsMLoadsMember Loads from the RFEM Model.Boolean
Surface LoadsSLoadsSurface Loads from the RFEM Model.Boolean
Free Line LoadsFLLoadsFree Line Loads from the RFEM Model.Boolean
Free Polygon LoadsPolyLoadsFree Polygon Loads from the RFEM Model.Boolean
Free Rectangular LoadsRectLoadsFree Rectangular Loads from the RFEM Model.Boolean
Load CasesLCasesLoad Cases from the RFEM Model.Boolean
Load CombosLCombosLoad Combinations from the RFEM Model.Boolean
Result CombosRCombosResult Combinations from the RFEM Model.Boolean
FilterFilterFilter RFEM ObjectsFilter
Model NameModel NameSegment of the name of the RFEM Model to get information fromText

Outputs

NameIDDescriptionType
RF NodesRF NodesNodes from the RFEM Model.RFEM
RF LinesRF LinesLines from the RFEM Model.RFEM
RF MembersRF MembersMembers from the RFEM Model.RFEM
RF SurfacesRF SurfacesSurfaces from the RFEM Model.RFEM
RF OpeningsRF OpeningsOpenings from the RFEM Model.RFEM
RF Nodal SupportsRF NodSupNodal Supports from the RFEM Model.RFEM
RF Line SupportsRF LineSupLine Supports from the RFEM Model.RFEM
RF Surface SupportsRF SrfcSupSurface Supports from the RFEM Model.RFEM
RF Member HingesRF MemberHingesMember Hinges from the RFEM Model.RFEM
RF Member EccentricitiesRF MemberEccMember Hinges from the RFEM Model.RFEM
RF Line HingesRF LineHingesLine Hinges from the RFEM Model.RFEM
Nodal ReleasesNodalReleasesNodal Releases to get from the RFEM Model.RFEM
Line ReleasesLineReleasesLine Releases to get from the RFEM Model.RFEM
Line Release TypesLineReleaseTypesLine Release Types to get from the RFEM Model.RFEM
RF Cross SectionsRF CroSecsCross Sections to get from the RFEM Model.RFEM
RF MaterialsRF MatMaterials from the RFEM Model.RFEM
RF Nodal LoadsRF NLoadsNodal Loads from the RFEM Model.RFEM
RF Line LoadsRF LLoadsLine Loads from the RFEM Model.RFEM
RF Member LoadsRF MLoadsMember Loads from the RFEM Model.RFEM
RF Surface LoadsRF SLoadsSurface Loads from the RFEM Model.RFEM
RF Free Line LoadsRF FLLoadsFree Line Loads from the RFEM Model.RFEM
RF Free Polygon LoadsRF PolyLoadsFree Polygon Loads from the RFEM Model.RFEM
RF Free Rectangular LoadsRF RectLoadsFree Rectangular Loads from the RFEM Model.RFEM
RF Load CasesRF LCasesLoad Cases from the RFEM Model.RFEM
RF Load CombosRF LCombosLoad Combinations from the RFEM Model.RFEM
RF Result CombosRF RCombosResult Combinations from the RFEM Model.RFEM

Site design © Robin Rodricks.   Parametric FEM Toolbox and associated data © 2024 Diego Apellániz.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service