We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️

Assembles and Disassembles RFMember objects.

Inputs

NameIDDescriptionType
LineLineLine or Curve to assemble the RFLine from.Curve
Start Cross-SectionSCroSecNumber of Start Cross-SectionInteger
Member NumberNoOptional index number to assign to the RFEM object.Integer
CommentCommentComment.Text
LineNoLineNoLine NumberInteger
Member TypeTypeMemberType: UnknownMemberType, Beam, Rigid, RibType, Truss, TrussOnlyN, Tension, Compression, Buckling, Cable, CableOnPulleys, ResultBeamType, DefinableStiffness, CouplingRigidRigid, CouplingRigidHinge, CouplingHingeHinge, CouplingHingeRigid, Spring, NullMember.Integer
Rotation Angle [°]βRotation Angle [°]Number
End Cross-SectionECroSecNumber of End Cross-SectionInteger
Start HingeSHingeNumber of Start HingeInteger
End HingeEHingeNumber of End HingeInteger
EccentricityEccNumber of EccentricityInteger
DivisionDivNumber of DivisionInteger
Taper ShapeTaperTaperShapeType: UnknownTaperShape, NoneTaper, Linear, Quadratic.Integer
FactorYKcr,yEffective length factor Kcr,yNumber
FactorZKcr,zEffective length factor Kcr,zNumber
Except MembersEMembersList of members (as string) NOT to be included.Text
Except SolidsESolidsList of solids (as string) NOT to be included.Text
Except SurfacesESfcsList of surfaces (as string) NOT to be included.Text
Include MembersIMembersList of members (as string) to be included.Text
Include SolidsISolidsList of solids (as string) to be included.Text
Include SurfacesISfcsList of surfaces (as string) to be included.Text
IntegrateStressesAndForcesTypeIntegrateIntegrateStressesAndForcesType: UnknownIntegration, WithinCuboidQuadratic, WithinCuboidGeneral, WithinCylinder, FromIncludeObjects.Integer
ParametersParamsParameters to integrate stresses and forces.Number
RF MemberRF MemberMember object from the RFEM model to modifyRFEM
ModifyModifyModify object?Boolean
DeleteDeleteDelete object?Boolean

Outputs

NameIDDescriptionType
RF MemberRF MemberOutput RFMember.RFEM

Site design © Robin Rodricks.   Parametric FEM Toolbox and associated data © 2024 Diego Apellániz.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service