We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Commands
Components
Parameters
Utility

Robots

ADDON. Version 1.6.6. Released on 22-Aug-2023. Provides 31 components. Created by Vicente Soler & others. Features 0 video tutorials.
Robots is a Grasshopper plugin for programming and simulating ABB, KUKA, UR and Staubli robots. Special care is taken to have feature parity between all manufacturers and have them behave as similar as possible. The plugin can also be used as a .NET library to create robot programs through scripting inside Rhino (using Python, C# or VB.NET). Advanced functionality is only exposed through scripting.

Components

Check collisions (Collisions)
Checks for possible collisions. Will test if any object from group A collide with any objects from group B.
Create program (Program)
Creates a program, checks for possible issues and fixes common mistakes.
Custom code (Custom)
Creates a program using manufacturer specific custom code. This program cannot be simulated
Remote connection (Remote)
Upload and run programs to UR or ABB controllers through a network. For ABB controllers you must install the 'ABB Robot Communication Runtime'.
Save program (SaveProg)
Saves a program to a text file.
Program simulation (Sim)
Rough simulation of the robot program, right click for playback controls
Kinematics (K)
Inverse and forward kinematics for a single target, or list of targets when using a robot system with coordinated robots.
Load frame (LoadFrame)
Loads a frame from the library.
Load robot system (LoadRobot)
Loads a robot system from the library.
Load tool (LoadTool)
Loads a tool from the library.
Create frame (Frame)
Creates a frame or work plane.
Create speed (Speed)
Creates a target speed.
Create target (Target)
Creates or modifies a target. Right click for additional inputs.
Create tool (Tool)
Creates a tool or end effector.
Deconstruct target (DeTarget)
Deconstructs a target. Right click for additional outputs.

Commands

Custom command (CustomCmd)
Custom command written in the manufacturer specific language
Group command (GroupCmd)
Group of commands
Message
Sends a text message to the teach pendant
Pulse DO (PulseDO)
Send a pulse to a digital output
Set AO (SetAO)
Set analog output
Set DO (SetDO)
Set digital output
Stop program (Stop)
Stops the program until an operator starts it again
Wait
Stops the program for a specific amount of time
Wait DI (WaitDI)
Stops the program until a digital input is turned on

Utility

Deconstruct program targets (DecProgTarg)
Exposes the calculated simulation data for all targets.
Degrees to radians (DegToRad)
Manufacturer dependent degrees to radians conversion.
From plane (FromPlane)
Returns a list of numbers from a plane
Get plane (GetPlane)
Get a plane from a point in space and a 3D rotation. The input has to be a list of 6 or 7 numbers.
Simple trail (Trail)
Draws a trail behind the TCP. To be used with the simulation component.

Parameters

Program parameter (Program)
This is a robot program
RobotSystem parameter (RobotSystem)
This is a robot system

Site design © Robin Rodricks.   Robots and associated data © 2024 Vicente Soler & others.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service