We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Commands
Components
Parameters
Utility

Check collisions

Checks for possible collisions. Will test if any object from group A collide with any objects from group B.

Inputs

NameIDDescriptionType
ProgramPProgramProgram
First setAFirst set of objects. Input a list of index values that correspond to the first collision group. The order is the same as the meshes output of the kinematics component. The environment would be an additional last mesh.Integer
Second setBSecond set of objects. Input a list of index values that correspond to the second collision group. The order is the same as the meshes output of the kinematics component. The environment would be an additional last mesh.Integer
EnvironmentESingle mesh object representing the environmentMesh
Environment planePIf attached to the robot, plane index where the environment is attached toInteger
Linear step sizeLsLinear step size in mm to check for collisionsNumber
Angular step sizeAsAngular step size in rad to check for collisionsNumber

Outputs

NameIDDescriptionType
Collision foundCTrue if a collision was foundBoolean
Target indexIIndex of the first target where a collision was found (targets are not necessarily calculated in order)Integer
Collided meshesMMeshes involved in the collisionMesh

Site design © Robin Rodricks.   Robots and associated data © 2024 Vicente Soler & others.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service