We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Commands
Components
Parameters
Utility

Create program

Creates a program, checks for possible issues and fixes common mistakes.

Inputs

NameIDDescriptionType
NameNProgram nameText
Robot systemRRobot system used in programRobotSystem
TargetsTList of targets or tool-paths.Toolpath
Init commandsCOptional list of commands that will run at the start of the programCommand
Multi-file indicesIOptional list of indices to split the program into multiple files. The indices correspond to the first target of the additional filesInteger
Step SizeSDistance in mm to step through linear motions, used for error checking and program simulation. Smaller is more accurate but slowerNumber

Outputs

NameIDDescriptionType
ProgramPProgramProgram
CodeCCodeText
DurationDProgram duration in secondsNumber
WarningsWWarnings in programText
ErrorsEErrors in programText

Site design © Robin Rodricks.   Robots and associated data © 2024 Vicente Soler & others.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service