We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Commands
Components
Parameters
Utility

From plane

Returns a list of numbers from a plane. The first 3 numbers are the x, y, and z coordinates of the origin. The last 3 or 4 values correspond to Euler angles in degrees or quaternion values respectively.

Inputs

NameIDDescriptionType
PlanePPlane to convert to Euler, quaternion or axis angle values.Plane
Robot systemRThe robot system will select the orientation type (ABB = quaternions, KUKA = Euler angles in degrees, UR = axis angles in radians). If this input is left unconnected, the 3D rotation will be expressed in quaternions.RobotSystem

Outputs

NameIDDescriptionType
NumbersNThe first 3 numbers are the x, y and z coordinates of the origin. The last 3 or 4 numbers represent a 3D rotation.Number

Site design © Robin Rodricks.   Robots and associated data © 2024 Vicente Soler & others.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service