Display Assemblage (AOaDisp) Display Assemblage with a set of modes | |
Extract Handles (AOeHandles) Extract essential Handle information for an AssemblyObject | |
Remove AssemblyObjects (AORem) Removes AssemblyObjects from an Assemblage given their indexes - updating Topology | |
Associate XData (AO<>XD) Associates XData to a list of AssemblyObjects Make sure the XData matches the corresponding AssemblyObject kinds present in the list | |
Deconstruct Assemblage (AOaDecon) Deconstructs an Assemblage Tree Branch indexes are the unique indexes of objects in the assemblage | |
Display Candidates (AOaDispCand) Displays Candidate Objects at last step in the Assemblage | |
Extract AOSet (AOaSet) Extracts the set of unique AssemblyObjects kinds used in an Assemblage | |
Extract Collision Mesh (AOeCMesh) Extract the collision mesh of an AssemblyObject | |
Extract Reference Plane (AOeRPlane) Extract AssemblyObject Reference Plane | |
ExtractTopology (AOaTopo) Extract connection data from an Assemblage | |
Extract Type (AOeType) Extract the Type of an AssemblyObject |
Construct AssemblyObject (AOCon) Construct an Assembly Object from relevant data | |
ConstructHandle (HandCon) Construct a Handle | |
Construct XData (XDCon) Construct an XData instance XData can be any kind of Xtended/Xtra data (Geometry, String, Numbers, ...) associated to an AssemblyObject Type | |
Deconstruct AssemblyObject (AODecon) Deconstruct an AssemblyObject | |
Deconstruct XData (XDDecon) Deconstructs an XData item | |
DisplayHandles (HandDisp) Displays Handle Type, weight, sender and receiver planes with rotations for all Handles in the input list | |
Reset AssemblyObject (AOReset) Resets an AssemblyObject's values to default | |
Construct Composite AssemblyObject (AOComCon) Construct a composite Assembly Object | |
Deconstruct Handle (HandDecon) Deconstruct Handle | |
Transform XData (XDTran) Apply a transformation to an XData item |
Construct Field N (AFieldN) Constructs an empty Field from a Box N cells along largest Box dimension | |
Construct Sparse Field (AFieldSp) Constructs an empty Field from a sparse list of points and optional topology information | |
Color Field (AFCol) Generates Field Point colors by scalar values | |
Construct Field XYZ (AFieldXYZ) Constructs an empty Field from a Box Individual n. of cells along Box XYZ dimensions | |
Deconstruct Field (AFDecon) Deconstructs a Field | |
Exogenous Settings (ExoSet) Collects exogenous related settings | |
Populate Field (AFPop) Populates a Field with Scalar, Vector, and integer Weight values (optional) |
Heuristic Display (HeuD) Display Heuristics as visual combination of AssemblyObjects | |
Heuristics Display Ex (HeuDeX) Display Heuristics as visual combination of AssemblyObjects - extended version | |
Heuristics Settings (HeuSet) Collects Heuristics related settings | |
Heuristics Writer (HeuWri) Generates Heuristics Set for an AssemblyObjects Set | |
Weigh Heuristics (HeuWeigh) Assigns custom integer weights to the Heuristics rules |
AssemblyObjects From JSON (JSON>AO) Load a list of AssemblyObjects from a JSON file saved with brute force method | |
AssemblyObjects To JSON (AO>JSON) Save a list of AssemblyObjects to a JSON file - brute force method |
Assembler Engine (AOaEngine) Assembler Engine Where the magic happens... |
Site design © Robin Rodricks.
Assembler and associated data © 2024 Co-de-iT (Computational Design Italy).
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.
Hosted by GitHub