We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Components
Engine
Exogenous
Heuristics
I/O
Post Processing

Assembler Engine

Assembler Engine
Where the magic happens...

Inputs

NameIDDescriptionType
AssemblyObjects SetAOsList of unique AssemblyObjects composing the setGeneric Data
Previous AssemblageAOpaList of preexisting AssemblyObjects, i.e. from an existing Assemblage (optional)Generic Data
Starting PlanePStarting Plane for the Assemblage Ignored if preexisting AssemblyObjects are presentPlane
Starting Object TypesOIndex of starting object from the AO set Ignored if preexisting AssemblyObjects are presentInteger
Heuristics SettingsHSHeuristics Settings for the AssemblageGeneric Data
Exogenous SettingsESExogenous Settings for the AssemblageGeneric Data
GogoRun Assemblage continuously until it reaches the targeted max n. of objectsBoolean
StepsRun an Assemblage step executing the specified n. of iterationsBoolean
N. IterationsnINumber of iterations to execute at each stepInteger
Target Max n. ObjectstNThe target Max n. of objects allowed in the assemblage This is an *approximate* target Assembler will try to reach, given the number of starting objects and iterations at each step With 1 starting object (default), 100 items per step and a target of 950 you will get 1001 objectsInteger
Reset SettingsrSReset Exogenous and Heuristics settings preserving the AssemblageBoolean
ResetRResets the AssemblageBoolean

Outputs

NameIDDescriptionType
AssemblageAOaThe AssemblageGeneric Data
Assemblage CountcThe number of objects in the AssemblageInteger

Site design © Robin Rodricks.   Assembler and associated data © 2024 Co-de-iT (Computational Design Italy).  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service