We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Geometry
Maths
NAN
Networks
Primitive
Streaming
Uncertainty
Utilities
Vectors

Heteroptera

ADDON. Version 7.9.2. Released on 28-Oct-2023. Provides 146 components. Created by Amin Bahrami (Helioripple Studio). Features 2 video tutorials.
Heteroptera is a plug-in for grasshopper comprised of a variety of tools in different categories that can be used as a toolbox, but it mostly focuses on Uncertainty and Generation.

Vectors

Display Tensors (Field@Point)
Display Field at point
Display Fied (Display Field)
Display Field
Field Contour (Contour)
Create MetaBall-Like contours out of a field
Field Wiper (FWiper)
Wipe out a field locally ba a geometric element as an attractor element.
It either weakens or enervates the tensors nearby to the given geometric object.
Field Booster (FBooster)
Boost a field's tensors by another field.
Field Projector (FProjector)
Project a field on a datum.
A datum can be: a Plane, MetaVector, Mesh, Surface, or another field
Rotate Field (FRotate)
Rotate a field's tensors by other fields
Traverse On Field (F-Traveler)
Creates the traverse path on a field from a source point
Transform By Field (Field-Xform)
Transform a geometry recursively through a field
Noise Field (Noise-F)
Generate a Simplex-Noise Field
Trap Field (TrapF)
Create 'Trap Field' by a Point, Curve, Plane, Surface, or a mesh
Monotone Field (MonoF)
Create a simple monotone field out of a vector
Curve Along Field (AlongF)
Create a field that is tangent-aligned to the given curve
Curvature Field (CurvatureF)
Create a field based on a curve's curvature'
On-Curve Field (CurF)
Create a curve Gaussian attractor field
Drag Field (DragF)
Create a drag field, 'Drag Field' represents the Gaussian effect of a single vector in an area with a certain distance.
Gaussian Effect Field (GPF)
Create a point attractor field with Gaussian decay within a certain distance
Radio Field (RadioF)
Create a Radio field out of a meta-vector's' elements
Surface Curvature Field (SCF)
Create a field influenced by a surface's curvature'
Radar Vector (Radar)
Generate circular antenna distributed vectors from input vectors
Eponential Effective Vectors (E-Vectors)
Calculates the exponential effective attraction vectors
Gaussian Effective Vectors (G-Vectors)
Calculates the Gaussian effective attraction vectors
Attractor
Magnetic attractor with normalized value. It is a quick multi-type multi-attractor returning a congestive always-normal value between 0~1
Bionic Attractor (Biottractor)
Advanced multi-attraction system for finding a Congestive value
Bulge
Bulge set of points by some Bulger points
Transforming Vectors are generated in 3-dimensional space by default, but Right-click to choose [Planar] mode if you desire to calculate it along the given plane
Similar Vectors (Similar Vector)
Selected Meta-Vector Element
Construct Meta-Vector (Meta-Vector)
Construct a meta-vector out of set of vector elements. A Meta-Vector is a conceptual class consisting of a set of vectors as its components.
Plane By Line (LinePlane)
Creates a plane by its corresponding line
Translated Plane (TransPlane)
Move a plane along its axises
Project On Vector (PVector)
Project a vector on another vector(direction).

Networks

Display Topology (TopoDisplay)
Display a network connection topology
Cell from Coordinated Network (NetRegion)
Create Regions and Dual-Topology from network topology
Decompose Dual-Network (CellTopology)
Extract all features of a dual topology
Cell from Topology (Cell By Topo)
Computes Topologic-Cells of a network
Flatten Inter-Network (FlatNet)
Breaks down inter-topology to flat topology
Construct Hyper-Index (HyperIndex)
Constructs a Hyper-Index
Modify Inter-Network (InterTopDraw)
Modify and visualize a network's Inter-Topology
Inter-Networt Topology (InterTopologyComponent)
Topology of connected nodes of different branches
Unflatten Inter-Network (UnflattNet)
Unflatten an Network into a InterNetwork.
It creates Inter-Topology from flat topology by partitioning the nodes
Network From Geometry (GeoNet)
Create a network topology from Mesh or Brep
Network From Lines (L-Net)
Creates a network from a set of crossing lines.
Proximity Network (ProxyNet)
Extract Proximity Network out of a list of points.
Proximity Inter-Network (H-Net)
Create an Inter-Network between adjacent points from multiple sets
Modify Topology (NetworkEditor)
Edit the topology of a network or create a network by topology
Reconstruct Topology (ReConstNet)
Recreate Lines from topology or convert different types of network topology.
Boolean Topology (TopoBoolean)
Perform Union, Subtraction, or Intersection on a pair of networks
Container Items Matcher (MatchContainers)
This component indicates which containers contain which items and which items belong to which containers.
It determines which items and containers are associated with each other.
Adjacent Items Matcher (MatchAdjacents)
Indicates which geometry is closest to which point and the reverse
Topology Of Adjacencies (Adjacency)
It Computes the adjacency relationship among a list of polylines
Travelling Salesman Problem (TSP)
Solves TSP within the given network with ant-colonies algorithm. It finds the optimum Path s which visits every node
Weighted MinSpanTree (MST)
Creates 'Minimum Spanning Tree' based on a pre-existed network including connection weights.
Minimum Spanning Tree (MST)
It creates Minimum Spanning Tree
Networt Matching Path (MatchingPath)
Find the closest path in the network related to the given curved
Shortest Route (ShortestRoute)
Find the shortest route through a network between two nodes
Space Syntax (SpaceSyntax)
Generate Space-Syntax out of a network
Display ArrowLines (DisplayArrowLines)
Displays lines with arrow
Enumerator
Enumerate geometries
Topology Embody (Embody)
Create Lines or Closed Polylines from topology

Uncertainty

Noise Oscilator (Noise)
Noise Oscillator(streaming noise)
Right-click to choose the internal timer (with three options), or turn-off the self-engine and use a grasshopper timer instead.
Wandering Vectors (Wandering)
Generating multiple live wandering vectors
Right-click to choose options if needed
Biased Distribution (Distribution)
It distributes a set of input points to different branches
Possibility By Attractor (Possib^A)
Calculates the possibility of existing points by their adjacency to set of attractors
Positional Possibility (PositionalPosib)
Calculates the possibility of the existing points by assigning the given values to them
Cheater Dice (Cheater_Dice)
Dice with unequal chances for items
Dice
Rolling a Dice containing possible Data, for N times and extract N random items
Slingshot Allocator (Slingshot)
Allocate each item of one list to random branches; distributions can be made by three different algorithms
Weighted Allocator (Chance)
Randomly Allocates Items to different branches by defining the chance of each branch. so each item tends to belong to the branch with a higher chance
Simplex Vector (SimplexVector)
Generates a Simplex-Noise Vector set
Curvy Point-Emiter (C-Emitter)
Emit a bunch of random point around the give curve
Random Direction (RND Direction)
Create random unit vectors by each iteration
Gaussian Random (GaussianRandom)
Generates Gaussian random numbers
Point Emitter (Emitter)
Emit a bunch of points from each source point (You can also use F5 key or Grasshopper Timer to refresh the component)
Right-click to choose [Planar] mode to generate points forced-lied on the given Plane
Random Position (RNDPOS)
Generate Random positions bounded by a rectangle, Z value Defines the Maximum possible distance for positions along the rectangle's normal direction.
Random Plane (RandomPlane)
Create a random plane on a point
Random Vectors (RandVect)
Create random vectors in random directions with diverse lengths in a specific domain.
Right-click to choose [Planar] mode if needed
Careless Range (CarelessRange)
Divide a domain into careless equivalent parts and return the numbers
Random Numbers (Random)
Generates random numbers
Random numbers are generated in a range of [0 to 1] in case of using 'Normal Mode' otherwise the range would be [-1 to 1] in 'Standard' or 'Gaussian' modes.
Randomize Numbers (Randomize)
Randomize Numbers by percentage
Seed Generator (Seed)
Generates a set of unique seeds in each recalling
Simplex Noise (SimplexNoise)
Generates a Simplex-Noise number set

Maths

Interpolate + (Interp+)
Interpolate a collection of almost every interpolative data
Weighted Average + (Wav+)
Solve the arithmetic weighted average for a set of items
The items could be:
{Number, Complex, Color, Vector, Point, Line, Domain 1D&2D, Plane, Box, TwistedBox, Rectangle, Circle, Arc, Transform, Curve, Surface and Mesh}
Closest Numbers (CN)
Find a set of closest Numbers to a specific number (The closest numbers in set D to number S)
Number Digitizer (Digitizer)
modularize(digitize) a number by specific Scope size
Numbers On Grid (GridNums)
Put numbers in a grid with a specified max column number and return the row number and the column number
In-Common Numbers (LCM/GMD)
Retrieve 'Greatest common divisor' and 'Least common multiple' from a set of integers
Min / Max (Extremes)
Extract the minimum and the maximum value of a list of numbers
Normalizer (Edge)
Normalize a list of numbers
Number Limiter (Boundary)
Limit a number within a specific domain
Interval Connection (IntervalConnection)
Check the connectivity of a pair of intervals
Intersect Domains (Domain^)
Calculate an interval by intersecting two intervals
Expand Domain (DExpand)
Expand or shrink a domain
Subtract Domains (Dom-)
Calculate the result of subtraction from a set of domains by another set of domains
Symmetric Domain (SymmetricDomain)
Generate the symmetrical domain based on 'O' and length of 'X'
Symmetric Domain Expand (SymetricDomainExpand)
BiExtend or shrink a domain with symmetrical value
Union Intervals (Dom+)
Merge and union a set of domains
Incline Value (Bias)
Bias a set of numbers by conic function
Right-click to use "Bipolar" mode if you need to bias numbers based on Bipolar Conic Function instead of Conic Function.
Graph-Mapper + (Mapper+)
External Graph mapper
Right-click to choose [AutoDomain] mode if you want to define Output domain based on input domain interval; otherwise it'll be set to 0-1 in "Normalized" mode.

Utilities

Camera Crane (Camera)
Adjusting the active or the specified viewport camera
Camera Story (Cam Story)
Create a storyline for camera.. Right-click and select [Automatic!] option to put this on auto sequenced mode or choose different available 'Interpolation modes' if you need.
Capture
Auto-naming Viewport Capture. Right-click and select [Automatic!] option to to automatic mode or choose the other options if you need.
Allocate By Key (Key-Allocator)
Allocate each item to a specific string for each branch
Right-click to choose [Preserve structure] if you want to maintain the given data structure and just add Sub Branches to the main Branches
Allocate By Index (i-Allocator)
Allocate each item to a specific index of branches. Right-Click to choose[Preserve structure] to maintain the given data structure and add Sub Branches to the main branches if needed.
Tools EmptyStructure (O-Tree)
Create an empty tree structure out of a list of paths
Tools ExtendBranch (ExtendPath)
Add an extra element at the beginning (Prepend) or end (Append) of a path
ToolsHeteroDispatch (Dispatch)
Dispatch the items in a list into multiple target lists based on a pattern of indexes.
Right-click to choose the [Purge Outputs] option to remove useless Output parameters
Pick Object (Selection)
Pick selected objects in rhino. . Right-click and select [Automatic!] option to interactively update with selection change if you need.
Allocate By Value (Domain-Allocator)
Allocate each item to specific branches by the position of its value within the range
Right-click on branch allocator icon and choose "Preserve structure" if you want to maintain data's structure and just add Sub Branches to the main Branches
GraphMapper Controller (GraphMapperController)
Controlling Interval, Decimal-Number and the number of sliders in a GenePool
GenePool Controller (Pool Controller)
GNC
Http Request (Http_Request)
Restful API Request
Encrypt / Decrypt (CodeMachine)
Encrypt and Decrypt a string with a password (key string)
Right-click to choose the method of encryption/decryption
ToolsUnicode (Unicode)
Generating Unicode Character
Pick Item (PickItem)
Allows to pick one or multiple items from a data-list or a data-tree.
The Rhino's reference object name will be displayed if the item is a referenced geometry and has a name.

Streaming

Mesh Traveler (MeshTraveler)
Mass additive Vector buffer, considering a mesh as a constraint
Number Buffer (NumberBuffer)
After being recalled, the input number is added to the sum of the previous input numbers.
Vector Buffer (VectorBuffer)
Once recalled, it adds the input vector to the previous stack of inputted vectors
Event Gate (Event)
Checks whether the data has been updated (data with a different value from the previous one) and only passes data (Kicks) if it new
Stream Freeze / Gate (Freeze/Gate)
The 'Gate' switch determines whether streaming data will be allowed to pass through or not
Holding Gate (Hold)
This feature prevents any issues caused by NULL items in the output. Instead of allowing NULL items to be inputted, it replaces them with the most recent valid data from its history.
Event Toggle (e-Toggle)
Boolean toggle responding to the first True value after a False. It can prevent downstream kicks by the menu option.
Ease Changes (Ease)
It changes numbers smoothly during lapses.
Glitch Reduction (GlitchReduction)
De-Glitching/Smoothing streaming numbers (replacing the irrelevant numbers with the earlier relevant ones)
Time-Shifter (TimeShift)
shift a list of changing data to n step before in its history
Capacitor
Multi-Step Buffer
Oil-Can (OilCan)
Every time it is invoked, it drops one item from the given list respectively
Tap Buffer (Tap)
Return an increasing number each time that the component is called (You can also use Internal timer, trigger button, [Win:F5] , [MacOs:Ctrl+R] key or Grasshopper Timer to refresh the component)
Display Particles (AgentDisplay)
Displays a trailing chain of a set of moving nodes
(if N>1 output is represented in Tree-structure)
Particle Trailer (Trailer)
Generate a set of lines from each point of the current list to their peers from the previous list of points

Geometry

Anchor Sweep (AnchorSweep)
Quick section sweep with anchor
Right-click to either impose [RoadLike] mode, or use [Horizontal] balancing
Fast Sweep (FastSweep)
Quick single-section sweep
Right-click to either impose [RoadLike] or [Horizontal] balancing modes
Directional Curve (DireCurve)
Convert a line to a directional curve based on a plane
Overlay
Overlay shapes in order
Geometric Shadow (Shadow)
Create a 2d drawing on a plane out of a set of objects. Right-click and select [Automatic!] option to put it into interactive computation mode if you need.
Find Regions (GeoRegion)
Create Regions from a list of curves
Group By Axis (AxisGroup)
Group a list of 2d lines by their own axis
Center
Returns the center of geometry and the Diameter of its bounding box as the Dimension
Planarize Curve (CPL)
Planarizing a curve Once working with multiple Curves: you can Right-click to choose the "ForAll" option if desire to Planarize all curves Based on the same Plane
Evaluate Rectangle (EvalRect)
Evaluate a rectangle at normalized{uv} parameter
Grid In Rectangle (Grid)
Create a grid of points using a rectangle. If you're not satisfied using the [Exact Size] of the cells, you can Right-click to choose the related option.
Modular Points (Modular)
Modularize(digitize) a point by specific Scope size
Right-click to choose Which Directions (X/Y/Z) are affected by Modularpoints
Shell From Grid (Shell)
Create Surface, Mesh or net from a Tree of points

NAN

Find Regional Cells (Region)
Create Regions from a list of curves
Backing Capture (Baking-capture)
{This component is no longer exists}Bake objects and capture auto-naming shots from them, it's useful for creating animation, using viewport's graphical-style

Primitive

Dual-Net ([NET])
Dual-Topology Network containing topological Regions
Hyper Index (h.Index)
Item Hyper-Index

Video Tutorials

Site design © Robin Rodricks.   Heteroptera and associated data © 2024 Amin Bahrami (Helioripple Studio).  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service