Term | term | Search term, for example 'food' or 'restaurant'. The term may also be business names, such as 'Starbucks'. If term is not included the endpoint will default to searching across businesses from a small number of popular categories. | Text |
Location | location | Required if either latitude or longitude is not provided. This string indicates the geographic area to be used when searching for businesses. Examples: 'New York City', 'NYC', '350 5th Ave, New York, NY 10118'. Businesses returned in the response may not be strictly within the specified location. | Text |
Latitude | LAT | Required if location is not provided. Latitude of the location you want to search nearby. | Number |
Longitude | LON | Required if location is not provided. Longitude of the location you want to search nearby. | Number |
Returns | returns | Number of business results to return. By default, it will return 20. Maximum is 1000, however every 50 will count as another API call which will count against the 5,000 daily call limit. | Integer |
Yelp API Key | key | Yelp API key string for access to Yelp resources. Or set an Environment Variable 'YELPAPIKEY' with your key as the string. | Text |