We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Color
Curve
Domain
List
Mesh
Number
Plane
Point
SubD
Surface
Transform
Twisted Box
Vector

Parameter Extrude Mesh

Create an extruded mesh from a profile curve along a vector, curve, or to a point from domain dividing {u} and {v} parameters, or by lengths between control points, or by angle accuracy, with the option of capping closed profile mesh extrusions.


-base methods by Mateusz Zwierzycki

Inputs

NameIDDescriptionType
ProfilePProfile curve to extrude as meshCurve
DirectionDExtrusion direction vector, curve, or point Input a vector to exrude along a vector Input a curve to exrude along a curve Input a point to extrude to a pointGeneric Data
Parameters UuDivision parameters along profile curve {u} domain for mesh faces ({u}0.0 = Profile start, {u}1.0 = Profile end) (unless Length is true or Angle is not 0.0) For best results {u} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
Parameters VvDivision parameters along extrusion direction {v} domain for mesh faces ({v}0.0 = Extrusion start, {v}1.0 = Extrusion end) (unless length {v} is true or angle {v} is not 0.0 while using a curve for extrusion direction) For best results {v} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
WeightedWIf True, parameters {u} distribution is weighted by the profile curves curvatureBoolean
LengthsLIf True, profile curves mesh face divisions are defined by the lengths between its control points instead of the {u} parameters (useful for conforming mesh face divisions to each segment of a polyline profile curve)Boolean
AngleAIf Angle is not 0.0, profile curves mesh face divisions are defined by angle accuracy in degrees instead of the {u} parameters (useful for conforming mesh face divisions to the curvature of the profile curve)Number
CapCCap the open ends of a closed profile curve mesh extrusionBoolean
TriangulateTTriangulate the mesh facesBoolean
Weighted VvWIf True, parameters {v} distribution is weighted by the extrusion direction curves curvature if a curve is used for the extrusion directionBoolean
Lengths VvLIf True, extrusion direction curves mesh face divisions are defined by the lengths between its control points instead of the {v} parameters if a curve is used for the extrusion direction (useful for conforming mesh face divisions to each segment of a polyline extrusion direction curve)Boolean
Angle VvAIf Angle is not 0.0, extrusion direction curves mesh face divisions are defined by angle accuracy in degrees instead of the {v} parameters if a curve is used for the extrusion direction (useful for conforming mesh face divisions to the curvature of the extrusion direction curve)Number

Outputs

NameIDDescriptionType
ExtrudedEResulting extrude meshMesh

Video Tutorials

Site design © Robin Rodricks.   Pufferfish and associated data © 2024 Michael Pryor.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service