We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Color
Curve
Domain
List
Mesh
Number
Plane
Point
SubD
Surface
Transform
Twisted Box
Vector

Twisted Box Pipe Variable

Create connected twisted boxes along the inside of a pipe-like surface from a separate set of {u} domain dividing parameters for each {v} parameter.

Inputs

NameIDDescriptionType
SurfaceSPipe-like surface to create twisted boxes along the inside ofSurface
Parameters U1Division parameters along pipe-like surface {u} domain at paramater {v1} (0.0 = {u}start, 1.0 = {u}end) For best results parameters should be between 0 and 1, in numerical order, non duplicate, and have the same amount of parameters as the other parameter {u} listsNumber
Parameters U2Division parameters along pipe-like surface {u} domain at paramater {v2} (0.0 = {u}start, 1.0 = {u}end) For best results parameters should be between 0 and 1, in numerical order, non duplicate, and have the same amount of parameters as the other parameter {u} listsNumber
Parameters U3Division parameters along pipe-like surface {u} domain at paramater {v3} (0.0 = {u}start, 1.0 = {u}end) For best results parameters should be between 0 and 1, in numerical order, non duplicate, and have the same amount of parameters as the other parameter {u} listsNumber
Parameters U4u⁴Division parameters along pipe-like surface {u} domain at paramater {v4} (0.0 = {u}start, 1.0 = {u}end) For best results parameters should be between 0 and 1, in numerical order, non duplicate, and have the same amount of parameters as the other parameter {u} listsNumber
Parameter V1Division parameter along pipe-like surface {v} domain that the first and fifth corners of the twisted boxes are on (0.0 = {v}start, 1.0 = {v}end) For best results parameter should be between 0 and 1 and be the lowest number of the {v} parametersNumber
Parameter V2Division parameter along pipe-like surface {v} domain that the second and sixth corners of the twisted boxes are on (0.0 = {v}start, 1.0 = {v}end) For best results parameter should be between 0 and 1 and be a larger number than parameter {v1} but a lower number than parameter {v3}Number
Parameter V3Division parameter along pipe-like surface {v} domain that the third and seventh corners of the twisted boxes are on (0.0 = {v}start, 1.0 = {v}end) For best results parameter should be between 0 and 1 and be a larger number than parameter {v2} but a lower number than parameter {v4}Number
Parameter V4v⁴Division parameter along pipe-like surface {v} domain that the fourth and eigth corners of the twisted boxes are on (0.0 = {v}start, 1.0 = {v}end) For best results parameter should be between 0 and 1 and be the largest number of the {v} parametersNumber
WeightedWIf True, parameters {u} distributions are weighted by the input pipe-like surface curvatureBoolean
FlipFFlip the twisted box flow if they are not flowing in the correct direction along the the inside of the pipe-like surfaceBoolean

Outputs

NameIDDescriptionType
Twisted BoxesTBResulting twisted boxes along the inside of the pipe-like surfaceTwisted Box

Video Tutorials

Site design © Robin Rodricks.   Pufferfish and associated data © 2024 Michael Pryor.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service