We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Color
Curve
Domain
List
Mesh
Number
Plane
Point
SubD
Surface
Transform
Twisted Box
Vector

Twisted Box Tube

Create a layered tube array of connected twisted boxes along a curve from domain dividing parameters.

Inputs

NameIDDescriptionType
CurveCCurve to create twisted box tube array alongCurve
RadiusROuter radius of the twisted box tube arrayNumber
ThicknessTThickness of the twisted box tube array, offset inward from the outer radius cornersNumber
Parameters UuDivision parameters along curve {u} domain (0.0 = Curve start, 1.0 = Curve end) For best results {u} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
Parameters VvDivision parameters around curve {v} domain (0.0 = Revolve min, 1.0 = Revolve max) For best results {v} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
Parameters WwDivision parameters along thickness {w} domain (0.0 = Radius, 1.0 = Thickness) For best results {w} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
WeightedWIf True, parameters {u} distribution is weighted by the input curves curvatureBoolean
OffsetODomain defined offset center location of the twisted box tube array in relation to the curve (0.0 to 0.0 = centered on curve)Domain
Rotation 1Rotation of the twisted box tube array around the radius centers, in degreesNumber
Rotation 2Rotation of the twisted box tube array around the curve, in degrees (if the twisted box tube array is centered on the curve the effect will look the same as rotation 1)Number

Outputs

NameIDDescriptionType
Twisted BoxesTBResulting twisted box tube array along curveTwisted Box

Video Tutorials

Site design © Robin Rodricks.   Pufferfish and associated data © 2024 Michael Pryor.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service