We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Color
Curve
Domain
List
Mesh
Number
Plane
Point
SubD
Surface
Transform
Twisted Box
Vector

Point Divide Curve Target Length

Divide a curve into equal lengths that are as close as possible to a target length.

Inputs

NameIDDescriptionType
CurveCCurve to divideCurve
TargetTTarget length of curve divisionsNumber
Division TypeDDetermines which closest division length is used 0 = Nearest (The closest length to the target length) 1 = Floor (The closest length smaller than or equal to the target length) 2 = Ceiling (The closest length larger than or equal to the target length)Integer
End PointEIf the curve is closed, include the end point (point that is duplicate with the start point)Boolean

Outputs

NameIDDescriptionType
PointsPDivision points at equal lengths along the curvePoint
TangentsTTangent vectors at division pointsVector
ParameterstParameter values at division pointsNumber
LengthLThe length value used for the divisionsNumber
Result BooleanRTrue if the target length was smaller than the curve length, False if the target length was larger than the curve lengthBoolean

Video Tutorials

Site design © Robin Rodricks.   Pufferfish and associated data © 2024 Michael Pryor.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service