We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Color
Curve
Domain
List
Mesh
Number
Plane
Point
SubD
Surface
Transform
Twisted Box
Vector

Twisted Box Consecutive Meshes

Create a layered array of connected twisted boxes consecutively between a set of meshes from the faces, works on quad and triangle faces. Meshes must have the same topology.

Inputs

NameIDDescriptionType
MeshesMSet of meshes to create twisted box array betweenMesh
Parameters WwDivision parameters between each meshes {w} domain ({w}0.0 = Mesh at M, {w}1.0 = Mesh at M +1) For best results {w} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
WeightedWIf True, parameters {w} distribution is weighted by the input mesh set and the interpolation path curvatureBoolean
LoopbackLIf True, allow the parameters {w} interpolation path to continue from the end back to the start as a closed loopBoolean
DegreeDCurvature degree of the {w} interpolation path, degree should be a positive odd numberInteger
Interpolation TypeIDetermines how the {w} interpolation path is interpolated 0 = Linear 1 = Chord 2 = Square Root 3 = UniformInteger

Outputs

NameIDDescriptionType
Twisted BoxesTBResulting twisted box array consecutively between meshesTwisted Box

Video Tutorials

Site design © Robin Rodricks.   Pufferfish and associated data © 2024 Michael Pryor.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service