We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Color
Curve
Domain
List
Mesh
Number
Plane
Point
SubD
Surface
Transform
Twisted Box
Vector

Twisted Box Through Meshes

Create a layered array of connected twisted boxes through a set of meshes from the faces, works on quad and triangle faces. Meshes must have the same topology.

Inputs

NameIDDescriptionType
MeshesMSet of meshes to create twisted box array throughMesh
Parameters WwDivision parameters through meshes {w} domain ({w}0.0 = Mesh at M start, {w}1.0 = Mesh at M end), unless Normalized is False For best results {w} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
NormalizedNIf False, the rules for {w} parameters are ({w}0.0 = Mesh at index 0, {w}Index number of last mesh = Mesh at last index) For best results {w} parameters should be between 0 and the index of the last mesh, in numerical order, and non duplicateBoolean
EqualizedEIf True, parameters {w} distribution is evaluated along the interpolation path without considering the locations of the input mesh setBoolean
WeightedWIf True, parameters {w} distribution is weighted by the input mesh set and the interpolation path curvatureBoolean
LoopbackLIf True, allow the parameters {w} interpolation path to continue from the end back to the start as a closed loop (if Normalized is False, increase the division parameters {w} range maximum by 1)Boolean
DegreeDCurvature degree of the {w} interpolation path, degree should be a positive odd numberInteger
Interpolation TypeIDetermines how the {w} interpolation path is interpolated 0 = Linear 1 = Chord 2 = Square Root 3 = UniformInteger

Outputs

NameIDDescriptionType
Twisted BoxesTBResulting twisted box array through meshesTwisted Box

Video Tutorials

Site design © Robin Rodricks.   Pufferfish and associated data © 2024 Michael Pryor.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service