We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Color
Curve
Domain
List
Mesh
Number
Plane
Point
SubD
Surface
Transform
Twisted Box
Vector

Parameter Pipe Mesh

Create a piped mesh along a curve from domain dividing {u} and {v} parameters, or by lengths between control points, or by angle accuracy, with various end types.


-base methods by Mateusz Zwierzycki

Inputs

NameIDDescriptionType
CurveCCurve to create pipe along as meshCurve
RadiusRRadius of the pipe meshNumber
Parameters UuDivision parameters along the curves {u} domain for mesh faces ({u}0.0 = Curve start, {u}1.0 = Curve end) (unless Length is true or Angle is not 0.0) For best results {u} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
Parameters VvDivision parameters around the curve {v} domain for mesh faces ({v}0.0 = Revolve min, {v}1.0 = Revolve max) For best results {v} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
WeightedWIf True, parameters {u} distribution is weighted by the curves curvaturesBoolean
LengthsLIf True, the curves mesh face divisions are defined by the lengths between its control points instead of the {u} parameters (useful for conforming mesh face divisions to each segment of a polyline curve)Boolean
AngleAIf Angle is not 0.0, the curves mesh face divisions are defined by angle accuracy in degrees instead of the {u} parameters (useful for conforming mesh face divisions to the curvature of the curve)Number
End TypeEDetermines how to end the pipe mesh 0 = None 1 = Flat 2 = RoundInteger
TriangulateTTriangulate the mesh facesBoolean

Outputs

NameIDDescriptionType
PipedPResulting pipe meshMesh

Video Tutorials

Site design © Robin Rodricks.   Pufferfish and associated data © 2024 Michael Pryor.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service