We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Color
Curve
Domain
List
Mesh
Number
Plane
Point
SubD
Surface
Transform
Twisted Box
Vector

Twisted Box Consecutive Surfaces

Create a layered array of connected twisted boxes consecutively between a set of surfaces from domain dividing parameters.

Inputs

NameIDDescriptionType
SurfacesSSet of surfaces to create twisted box array betweenSurface
Parameters UuDivision parameters along surface {u} domains ({u}0.0 = Surface starts, {u}1.0 = Surface ends) For best results {u} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
Parameters VvDivision parameters along surface {v} domains ({v}0.0 = Surface starts, {v}1.0 = Surface ends) For best results {v} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
Parameters WwDivision parameters between each surfaces {w} domain ({w}0.0 = Surface at S, {w}1.0 = Surface at S +1) For best results {w} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
WeightedWIf True, parameters {w} distribution is weighted by the input surface set and the interpolation path curvatureBoolean
LoopbackLIf True, allow the parameters {w} interpolation path to continue from the end back to the start as a closed loopBoolean
DegreeDCurvature degree of the {w} interpolation path, degree should be a positive odd numberInteger
Interpolation TypeIDetermines how the {w} interpolation path is interpolated 0 = Linear 1 = Chord 2 = Square Root 3 = UniformInteger
RefitROptional Refit match method. (No Integer or 0 = Off, Integer greater than 0 = On and surface degree of refit) If an integer greater than zero, Refit match method is used if possible. When input surfaces are refit their control points are redistributed, added to, and removed from based on the surfaces curvature and the input integer degree, while trying to maintain their shapes. Refit results in tighter shaped twisted boxes, with curvature based control point distribution.Integer
Point SamplePOptional Point Sample match method. (No Integer or 0 = Off, Integer greater than 0 = On and amount of sample points) If an integer greater than zero, Point Sample match method is used. When input surfaces are sampled their control points are recreated by equally dividing the surface by the input integer point count. Point Sample results in looser shaped twisted boxes, with uniform control point distribution.Integer

Outputs

NameIDDescriptionType
Twisted BoxesTBResulting twisted box array consecutively between surfacesTwisted Box

Video Tutorials

Site design © Robin Rodricks.   Pufferfish and associated data © 2024 Michael Pryor.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service