We need your help! 🔥
Please consider disabling your ad-blocker to support this website! 🔑
We are a free, community-supported website! 🥰
We only display small unobtrusive ads which help us stay online! 💯
Thank you in advance! ❤️
Color
Curve
Domain
List
Mesh
Number
Plane
Point
SubD
Surface
Transform
Twisted Box
Vector

Parameter Loft Mesh

Create a lofted mesh through a set of section curves from domain dividing {u} and {v} parameters, or by lengths between control points, or by angle accuracy, with optional start and end points to loft to.


-base methods by Mateusz Zwierzycki

Inputs

NameIDDescriptionType
SectionsSSet of section curves to loft through as meshCurve
Parameters UuDivision parameters along section curves {u} domain for mesh faces ({u}0.0 = Section start, {u}1.0 = Section end) (unless Length is true or Angle is not 0.0) For best results {u} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
Parameters VvDivision parameters between each section curve {v} domain for mesh faces ({v}0.0 = Section at S, {v}1.0 = Section at S +1) For best results {v} parameters should be between 0 and 1, in numerical order, and non duplicateNumber
WeightedWIf True, parameters {u} distribution is weighted by the section curves curvaturesBoolean
LengthsLIf True, section curves mesh face divisions are defined by the lengths between their control points instead of the {u} parameters (useful for conforming mesh face divisions to each segment of polyline section curves)Boolean
AngleAIf Angle is not 0.0, section curves mesh face divisions are defined by their angle accuracy in degrees instead of the {u} parameters (useful for conforming mesh face divisions to the curvatures of the section curves)Number
ClosedCClosed loft, if true the last section curve will loft back to the first section curve (or to the optional start or end point)Boolean
TriangulateTTriangulate the mesh facesBoolean
Point StartsPOptional start point of the mesh loft (can also be used to cap the start of a mesh loft which has a closed start section curve)Point
Point EndePOptional end point of the mesh loft (can also be used to cap the end of a mesh loft which has a closed end section curve)Point

Outputs

NameIDDescriptionType
LoftedLResulting loft meshMesh

Video Tutorials

Site design © Robin Rodricks.   Pufferfish and associated data © 2024 Michael Pryor.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service