Grasshopper Docs

Community documentation for Grasshopper add-ons & plugins

Color
Curve
Domain
List
Mesh
Number
Plane
Point
SubD
Surface
Transform
Twisted Box
Vector

Get the lengths along a curve between points on the curve (or optionally parameters on the curve), if points are not on the curve they will be pulled to it.

Inputs

NameIDDescriptionType
CurveCCurve to get lengths alongCurve
PointsPSet of points on curve to get lengths betweenPoint
ParameterstOptional set of parameters on curve to get lengths between instead of points (will override points if points are also input)Number
NormalizedNIf true, the lengths output is normalized (0.0 - 1.0)Boolean

Outputs

NameIDDescriptionType
LengthsLLengths along curve between points on curveNumber
ParameterstCurve parameters at the points on curveNumber

Video Tutorials

Site design © Robin Rodricks.   Pufferfish and associated data © 2023 Michael Pryor.  
Rhinoceros and Grasshopper are registered trademarks of Robert McNeel & Associates.  Hosted by GitHub

Report an Issue  |  Terms of Service