Surface | S | Pipe-like surface to create twisted boxes along the inside of | Surface |
Parameters U | u | Division parameters along pipe-like surface {u} domain (0.0 = {u}start, 1.0 = {u}end)
For best results parameters should be between 0 and 1, in numerical order, and non duplicate | Number |
Parameter V1 | v¹ | Division parameter along pipe-like surface {v} domain that the first and fifth corners of the twisted boxes are on
(0.0 = {v}start, 1.0 = {v}end)
For best results parameter should be between 0 and 1 and be the lowest number of the {v} parameters | Number |
Parameter V2 | v² | Division parameter along pipe-like surface {v} domain that the second and sixth corners of the twisted boxes are on
(0.0 = {v}start, 1.0 = {v}end)
For best results parameter should be between 0 and 1 and be a larger number than parameter {v1} but a lower number than parameter {v3} | Number |
Parameter V3 | v³ | Division parameter along pipe-like surface {v} domain that the third and seventh corners of the twisted boxes are on
(0.0 = {v}start, 1.0 = {v}end)
For best results parameter should be between 0 and 1 and be a larger number than parameter {v2} but a lower number than parameter {v4} | Number |
Parameter V4 | v⁴ | Division parameter along pipe-like surface {v} domain that the fourth and eigth corners of the twisted boxes are on
(0.0 = {v}start, 1.0 = {v}end)
For best results parameter should be between 0 and 1 and be the largest number of the {v} parameters | Number |
Weighted | W | If True, parameters {u} distribution is weighted by the input pipe-like surface curvature | Boolean |
Flip | F | Flip the twisted box flow if they are not flowing in the correct direction along the the inside of the pipe-like surface | Boolean |