Surface A | A | Surface to create twisted box array from | Surface |
Surface B | B | Surface to create twisted box array to | Surface |
Parameters U | u | Division parameters along surface {u} domains ({u}0.0 = Surface starts, {u}1.0 = Surface ends)
For best results {u} parameters should be between 0 and 1, in numerical order, and non duplicate | Number |
Parameters V | v | Division parameters along surface {v} domains ({v}0.0 = Surface starts, {v}1.0 = Surface ends)
For best results {v} parameters should be between 0 and 1, in numerical order, and non duplicate | Number |
Parameters W | w | Division parameters between surfaces {w} domain ({w}0.0 = Surface A, {w}1.0 = Surface B)
For best results {w} parameters should be between 0 and 1, in numerical order, and non duplicate | Number |
Refit | R | Optional Refit match method.
(No Integer or 0 = Off, Integer greater than 0 = On and surface degree of refit)
If an integer greater than zero, Refit match method is used if possible. When input surfaces are refit their control points are redistributed, added to, and removed from based on the surfaces curvature and the input integer degree, while trying to maintain their shapes. Refit results in tighter shaped twisted boxes, with curvature based control point distribution. | Integer |
Point Sample | P | Optional Point Sample match method.
(No Integer or 0 = Off, Integer greater than 0 = On and amount of sample points)
If an integer greater than zero, Point Sample match method is used. When input surfaces are sampled their control points are recreated by equally dividing the surface by the input integer point count. Point Sample results in looser shaped twisted boxes, with uniform control point distribution. | Integer |