Curve A | A | Curve to create twisted box array from | Curve |
Curve B | B | Curve to create twisted box array to | Curve |
Thickness | T | Overall thickness of the twisted box array, offset from the curves | Number |
Parameters U | u | Division parameters between curves {u} domain ({u}0.0 = Curve A, {u}1.0 = Curve B)
For best results {u} parameters should be between 0 and 1, in numerical order, and non duplicate | Number |
Parameters V | v | Division parameters along curve {v} domains ({v}0.0 = Curve starts, {v}1.0 = Curve ends)
For best results {v} parameters should be between 0 and 1, in numerical order, and non duplicate | Number |
Parameters W | w | Division parameters along thickness {w} domain ({w}0.0 = Curves, {w}1.0 = Thickness)
For best results {w} parameters should be between 0 and 1, in numerical order, and non duplicate | Number |
Weighted | W | If True, parameters {v} distribution is weighted by the input curves curvatures | Boolean |
Refit | R | Optional Refit match method.
(No Integer or 0 = Off, Integer greater than 0 = On and curve degree of refit)
If an integer greater than zero, Refit match method is used if possible. When input curves are refit their control points are redistributed, added to, and removed from based on the curves curvature and the input integer degree, while trying to maintain their shapes. Refit results in tighter shaped twisted boxes, with curvature based control point distribution. | Integer |
Point Sample | P | Optional Point Sample match method.
(No Integer or 0 = Off, Integer greater than 0 = On and amount of sample points)
If an integer greater than zero, Point Sample match method is used. When input curves are sampled their control points are recreated by equally dividing the curve by the input integer point count. Point Sample results in looser shaped twisted boxes, with uniform control point distribution. | Integer |