Profile | P | Profile curve or surface to extrude as twisted boxes
Profile should preferably be a quadrilateral polygon (4 sided polyline with 4 corners). If profile is not a quadrilateral polygon it will be converted. Profile does not need to be planar or closed. Triangles are acceptable. | Curve |
Direction | D | Extrusion direction vector, curve, or point
Input a vector to exrude along a vector
Input a curve to exrude along a curve
Input a point to extrude to a point | Generic Data |
Parameters T | t | Division parameters along the extrusion {t} domain (0.0 = Extrusion start, 1.0 = Extrusion end)
For best results parameters should be between 0 and 1, in numerical order, and non duplicate | Number |
Weighted | W | If True, parameters {t} distribution is weighted by the input direction curves curvature if a curve is used for the extrusion direction | Boolean |